Connect field values do not display in e-mail notifications


Table of contents



Symptoms

When an issue that contains Elements Connect fields with a dependency to the  $issue variable in their query is created/edited, the field ID displays in the e-mail notification instead of the actual display value. 




Cause

When an e-mail notification is sent, Jira asks Elements Connect for the field value but does not provide the issue context. For now, Jira only supports the following context parameters for now.

If the Connect field query has dependencies to $issue, they cannot be resolved and the value cannot be retrieved.

Resolution

There is currently no solution to this problem but they are some possible workarounds depending on the use case.


Workaround #1

Whenever possible, configure a custom display view query without dependencies to $issue, and use $currentCustomfieldValue instead.

Workaround #2

It is possible to use a Snapshot field instead of a Live field. As the displayed value of a Snapshot field is directly stored in Jira, it will be retrieved and displayed into the e-mail.