Issues with the local Jira REST API datasource
Symptom
You may experience some issues when using the preconfigured “Jira REST API” datasource, as outlined below:
A. Elements Connect
In a basic Connect field configuration:

/rest/nfeed/3.0/nfeed/admin/test-configuration/customfield_23974/test/EDIT_VIEW [c.v.j.p.s.s.r.e.d.url.http.CookieJiraAuthHttpClient] ServletContext.getContext() is null. Rest Api Authentication failed.
B. Automation for Jira
Automation rules whose action is to set the value of Connect fields that are linked to the local pre-configured Jira REST API fail to run with the following errors:
/rest/plugins/1.0/installed-marketplace [c.v.j.p.s.s.r.e.d.url.http.CookieJiraAuthHttpClient] ServletContext.getContext() is null. Rest Api Authentication failed.
/rest/plugins/1.0/installed-marketplace [c.v.j.p.s.s.r.e.d.url.http.SessionIdGenerator] ServletContext.getContext() is null. Rest Api Authentication failed.
C. EazyBI
Import for Connect fields linked to the local pre-configured Jira REST API fails in EazyBI with the following error:
"Errors: {}\nError Messages: [Error ! Response code from server : '403']"
In the same time the following error is printed out in the atlassian-jira.log file
"ServletContext.getContext() is null. Rest Api Authentication failed."
Cause
Security constraints specific to your environment may restrict access to the context, and Jira cookies (such as CookieJiraAuthHttpClient) may be missing.
As a result, this datasource may be blocked, since the preconfigured local Jira REST API datasource does not rely on any HTTP authentication.
Resolution
The only workaround solution is to create a direct connection to the local Jira REST API in Elements Connect and link your Connect fields to it.
Go to the Datasources tab
Create a URL datasource
Provide the required information to authenticate to your Jira REST API.

Edit your Connect fields and replace the preconfigured Jira REST API datasource with the new one
Try to reproduce the problem
For Automation: Enable the 'Execute this rule immediately' option
From the Automation rule configuration screen, check the "Execute this rule immediately" when the rule is triggered, instead of in the background" option.