Skip to main content
Skip table of contents

Automation and EazyBI fail to populate or import Connect fields linked to the local Jira REST API datasource


Symptom

 Automation for Jira:

Automation rules whose action is to set the value of Connect fields that are linked to the local pre-configured Jira REST API fail to run with the following errors:

CODE
2019-12-24 07:45:19,518 automation-rule-executor:thread-5 ERROR admin 834x458x1 1ukf1fu 83.118.198.126 /rest/plugins/1.0/installed-marketplace [c.v.j.p.s.s.r.e.d.url.http.CookieJiraAuthHttpClient] ServletContext.getContext() is null. Rest Api Authentication failed.
2019-12-24 07:45:19,518 automation-rule-executor:thread-5 ERROR admin 834x458x1 1ukf1fu 83.118.198.126 /rest/plugins/1.0/installed-marketplace [c.v.j.p.s.s.r.e.d.url.http.SessionIdGenerator] ServletContext.getContext() is null. Rest Api Authentication failed.


EazyBI:

Import for Connect fields linked to the local pre-configured Jira REST API fails in EazyBI with the following error:

CODE
"Errors: {}\nError Messages: [Error ! Response code from server : '403']"
In the same time the following error is printed out in the atlassian-jira.log file
"ServletContext.getContext() is null. Rest Api Authentication failed."





Cause

The pre-configured local Jira REST API datasource does not rely on any HTTP authentication, resulting in those errors. 




Resolution

The only workaround solution is to create a direct connection to the local Jira REST API in Elements Connect and link your Connect fields to it. 

  • Set a URL datasource like:
    • URL: <JIRA_BASE_URL>/rest

    • Basic Auth with credentials

    • Content type: JSON

  • Switch the field to this newly created datasource


For Automation: Enable the 'Execute this rule immediately' option

From the Automation rule configuration screen, check the "Execute this rule immediately" when the rule is triggered, instead of in the background" option.


JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.