Jira Service Management notifications show Elements Connect field Key with JSON tags


Symptom

When a Connect field of type Live is set in a Jira Service Management project, the received notification will show the Elements Connect field with the key value stored as JSON object in version 6 (XML tag in version 5).


Here's the field set on the JSM portal:

And here's the received JSM notification:


The displayed value in JSM notification will be:

  • Elements Connect version 6:
    {"keys":["xxxxx"]}
  • Elements Connect version 5:
    <content> <value>xxxxx</value> </content>

    Where xxxxx is the Key value of the Connect field.








Cause

The above is the case for any Connect field of type Live displayed in JSM notification. Having a Display view configured and/or a dependency to $issue has no impact on the above.

In fact, the Jira Service Management notification fetches directly the field stored value from Jira's database as it is without giving us the possibility to render the field properly as it's displayed on Jira issue (for a Live field, it's the Key value that's stored in Jira DB as JSON object).



Resolution

There's no actual solution for the current situation as we are facing this Atlassian limitation; however, there are possible workarounds:

  • Use a Snapshot field (in case the Live field was single value) as Snapshot fields don't have a Key and the Template (what's seen on the Jira issue) is what's stored in Jira's database; therefore, it will be displayed correctly in the JSM notification. Please refer to this page to learn more about the difference between Live and Snapshot fields.
  • Use a dedicated application to send the notification and not the native JSM notification.