Skip to main content
Skip table of contents

Performance issues with connected fields

Symptoms

Users may report one or more of the following:

  • Connected field takes a long time to load (spinner visible for several seconds)

  • Dropdown options take time to appear after clicking the field

  • Slow response when typing in a field (delayed search results)

  • Field loads slowly on issue create, edit, or view screens

  • Results appear inconsistently or intermittently (sometimes fast, sometimes slow)

  • Field returns no results or fails to load after a long delay

  • First load is slow, but subsequent loads are faster

Causes

Performance issues root cause can be found all over the data lifecycle and for various reasons.

1. Volume of requested data

When a large amount of data is requested, it impacts performance at multiple levels:

  • Data retrieval (Data source)
    The more data you request, the longer the data source takes to respond.
    Note that a timeout is applied to REST API calls (up to 1 minute). Check the documentation here for more info.

  • Data processing (Elements Connect)
    Large responses require more processing (JSON parsing, template evaluation, dependencies resolution), which can increase response time.

  • Data rendering (Jira)
    Displaying a large number of options in a field can slow down the user interface (dropdown loading, scrolling, searching).

2. Number of requests

Each time a connected field is loaded (create, edit, view), one or more requests are sent across the system:

  • to the data source

  • to the Elements Connect application

  • to the Jira platform

Under normal conditions, this is not an issue. However, during peak usage, each app’s API may enforce rate limiting to a given user instance.

Check usage limitations doc here to find out more about Elements Connect rate limiting.

3. Connectivity issues

Performance issues can also be caused by connectivity or configuration problems with the data source:

  • network latency

  • IP allowlist not configured

  • authentication issues

  • API rejecting requests

You can use the Configuration Tester to measure response time and identify where delays occur (request, processing, or response). Check the documentation here for more info.

Resolution

Performance issues are often temporary and context-dependent but can be prevented with a few good practices. Check the tutorial here How to improve performance .

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.