Skip to main content
Skip table of contents

URL datasources authentication fails after restoring a backup

This behavior has been introduced since Elements Connect 8.0.2.

Symptoms

  • After restoring an Elements Connect backup, OAuth-based or token-authenticated datasources are no longer working.

  • Access tokens appear to be missing


Cause

  • For security reasons, access tokens are no longer included in backup exports, keeping sensitive secrets out of backup files.


Resolution

  • After restoring your configuration from a backup, re-authentication will be required in the relevant datasources (either re-run the OAuth flow or re-enter the token).

  • Token re-authentication should be treated as a standard post-restore step.

JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.